首页 » 软件编程 » 易语言

易语言高级表格选择任意行列获取内容的代码示例

易语言 2021-12-12

高级表格取选择任意行列的内容

.版本 2
.支持库 eGrid
.程序集 窗口程序集1
.子程序 __启动窗口_创建完毕
高级表格1.置数据 (1, 1, #表格常量.文本型, “我”)
高级表格1.置数据 (1, 2, #表格常量.文本型, “爱”)
高级表格1.置数据 (1, 3, #表格常量.文本型, “你”)
高级表格1.置数据 (1, 4, #表格常量.文本型, “你”)
高级表格1.置数据 (1, 5, #表格常量.文本型, “爱”)
高级表格1.置数据 (1, 6, #表格常量.文本型, “我”)
高级表格1.置数据 (2, 1, #表格常量.文本型, “易”)
高级表格1.置数据 (2, 2, #表格常量.文本型, “语”)
高级表格1.置数据 (2, 3, #表格常量.文本型, “言”)
高级表格1.置数据 (2, 4, #表格常量.文本型, “我”)
高级表格1.置数据 (2, 5, #表格常量.文本型, “爱”)
高级表格1.置数据 (2, 6, #表格常量.文本型, “你”)
高级表格1.置数据 (3, 1, #表格常量.文本型, “我”)
高级表格1.置数据 (3, 2, #表格常量.文本型, “爱”)
高级表格1.置数据 (3, 3, #表格常量.文本型, “你”)
高级表格1.置数据 (3, 4, #表格常量.文本型, “易”)
高级表格1.置数据 (3, 5, #表格常量.文本型, “语”)
高级表格1.置数据 (3, 6, #表格常量.文本型, “言”)
高级表格1.置数据 (4, 1, #表格常量.文本型, “脚”)
高级表格1.置数据 (4, 2, #表格常量.文本型, “本”)
高级表格1.置数据 (4, 3, #表格常量.文本型, “之”)
高级表格1.置数据 (4, 4, #表格常量.文本型, “家”)
高级表格1.置数据 (4, 5, #表格常量.文本型, “j”)
高级表格1.置数据 (4, 6, #表格常量.文本型, “b”)
高级表格1.置数据 (4, 7, #表格常量.文本型, “5”)
高级表格1.置数据 (5, 1, #表格常量.文本型, “1”)
高级表格1.置数据 (5, 2, #表格常量.文本型, “.”)
高级表格1.置数据 (5, 3, #表格常量.文本型, “n”)
高级表格1.置数据 (5, 4, #表格常量.文本型, “e”)
高级表格1.置数据 (5, 5, #表格常量.文本型, “t”)
高级表格1.置数据 (6, 1, #表格常量.文本型, “共”)
高级表格1.置数据 (6, 2, #表格常量.文本型, “同”)
高级表格1.置数据 (6, 3, #表格常量.文本型, “学”)
高级表格1.置数据 (6, 4, #表格常量.文本型, “习”)
高级表格1.置数据 (6, 5, #表格常量.文本型, “吧”)
.子程序 _按钮_取表格行_被单击
.局部变量 起始列, 整数型
.局部变量 终止列, 整数型
.局部变量 i, 整数型
.局部变量 数据, 文本型
起始列 = 到数值 (编辑框_行.内容)
输出调试文本 (“起始列:” + 到文本 (起始列))
终止列 = 高级表格1.列数
输出调试文本 (“终止列:” + 到文本 (终止列))
.变量循环首 (1, 终止列, 1, i)
  .如果真 (到文本 (高级表格1.取数据 (起始列, i)) ≠ “假”) ' 因未选择的单元格会返回假,所以要去掉取出的文本“假”字
    数据 = 数据 + 到文本 (高级表格1.取数据 (起始列, i))
  .如果真结束
.变量循环尾 ()
信息框 (数据, 0, )
.子程序 _按钮_取表格列_被单击
.局部变量 起始行, 整数型
.局部变量 终止行, 整数型
.局部变量 i, 整数型
.局部变量 数据, 文本型
起始行 = 到数值 (编辑框_列.内容)
输出调试文本 (“起始行:” + 到文本 (起始行))
终止行 = 高级表格1.行数
输出调试文本 (“终止行:” + 到文本 (终止行))
.变量循环首 (1, 终止行, 1, i)
  .如果真 (到文本 (高级表格1.取数据 (起始行, i)) ≠ “假”) ' 因未选择的单元格会返回假,所以要去掉取出的文本“假”字
    数据 = 数据 + 到文本 (高级表格1.取数据 (i, 起始行))
  .如果真结束
.变量循环尾 ()
信息框 (数据, 0, )
.子程序 _按钮_取表格任意行列_被单击
.局部变量 起始行, 整数型
.局部变量 起始列, 整数型
.局部变量 终止行, 整数型
.局部变量 终止列, 整数型
.局部变量 i, 整数型
.局部变量 数据, 文本型
.局部变量 N, 整数型
起始行 = 高级表格1.取选择起始行 ()
终止行 = 高级表格1.取选择终止行 ()
起始列 = 高级表格1.取选择起始列 ()
终止列 = 高级表格1.取选择终止列 ()
.如果真 (起始行 = -1 或 起始列 = -1)
  信息框 (“未选择表格!”, 0, )
  返回 ()
.如果真结束
.变量循环首 (起始行, 终止行, 1, N)
  .变量循环首 (起始列, 终止列, 1, i)
    数据 = 数据 + 到文本 (高级表格1.取数据 (N, i))
  .变量循环尾 ()
.变量循环尾 ()
信息框 (数据, 0, )

运行结果:

易语言高级表格选择任意行列获取内容的代码示例

总结

以上就是这篇文章的全部内容了,希望本文的内容对大家的学习或者工作具有一定的参考学习价值,谢谢大家对www.580doc.com的支持。如果你想了解更多相关内容请查看下面相关链接


上一篇:易语言卷帘式菜单组件使用教程下一篇:易语言分隔条组件使用方法
程序园_程序员的世界 Copyright © 2020- www.580doc.com. Some Rights Reserved.