首页 » 软件编程 » 易语言

易语言取mp3相关信息的教学

易语言 2021-12-12

利用编程软件"易语言"取MP3的备注等等。

1、启动易语言。

易语言取mp3相关信息的教学

2、弹出“易语言”的窗口后,在菜单栏中鼠标左键单击第一个,标题为“F.程序”的菜单。

易语言取mp3相关信息的教学

3、在弹出的新菜单框中鼠标左键单击第一个,标题为“N.新建”的项。

易语言取mp3相关信息的教学

4、然后在新弹出的标题为“新建:”的窗口中,在窗口左边的列表中鼠标左键单击标题为“Windows 空白程序”的项;

再在右边新出现的列表中鼠标左键单击标题为“Windows窗口程序”的项;

以上按顺序完成后,鼠标左键单击标题为“确定(O)”的按钮。

易语言取mp3相关信息的教学

5、鼠标左键双击灰色背景的窗口,然后页面会转到“代码编辑页”。

易语言取mp3相关信息的教学

6、在“__启动窗口_创建完毕“子程序下编写代码。

易语言取mp3相关信息的教学

7、写好代码后开始测试效果。

易语言取mp3相关信息的教学

8、我测试的MP3文件是”初音“的一首歌曲的。

代码:

.版本 2

.支持库 spec


.子程序 __启动窗口_创建完毕

.局部变量 w, 字节集

.局部变量 e, 字节集

.局部变量 d, 整数型


w = 读入文件 (取运行目录 () + “\1.mp3”)

d = 取字节集长度 (w) - 倒找字节集 (w, 到字节集 (“TAG”), ) + 1

e = 取字节集右边 (w, d)

调试输出 (d, e, 到文本 (取字节集左边 (e, 3)))

.如果 (取字节集左边 (e, 3) ≠ 到字节集 (“TAG”))

  ' 错误

.否则

  信息框 (“备注 =” + 到文本 (取字节集中间 (e, 98, 28)) + #换行符 + “发行年 =” + 到文本 (取字节集中间 (e, 94, 4)) + #换行符 + “专辑名 =” + 到文本 (取字节集中间 (e, 64, 30)) + #换行符 + “歌手名 =” + 到文本 (取字节集中间 (e, 34, 30)) + #换行符 + “歌曲名 = ” + 到文本 (取字节集中间 (e, 4, 30)), 0, )

易语言取mp3相关信息的教学

【作者】:


上一篇:易语言编译失败的解决办法下一篇:易语言手动备份方法
程序园_程序员的世界 Copyright © 2020- www.580doc.com. Some Rights Reserved.