首页 » 软件编程 » 易语言

易语言获取进程id的方法

易语言 2021-12-12

本文介绍如何通过易语言,来获取进程ID。(本次教程不需要用到dll和模块,十分简单)

1、启动易语言,新建“Windows窗口程序”。

易语言获取进程id的方法

2、建立一个“按钮”

易语言获取进程id的方法

3、双击“按钮”

易语言获取进程id的方法

4、放入以下代码:

.版本 2

.支持库 eAPI

.支持库 spec

.程序集 窗口程序集1

.子程序 _按钮1_被单击

.局部变量 进程信息, 进程信息, , "0"

.局部变量 n, 整数型

.局部变量 取进程ID, 整数型

进程信息 = 取系统进程列表 ()

.计次循环首 (取数组成员数 (进程信息), n)

  .如果真 (进程信息 [n].进程名称 = “e.exe”)

    取进程ID = 进程信息 [n].进程标识符

    跳出循环 ()

  .如果真结束

.计次循环尾 ()

调试输出 (取进程ID)

易语言获取进程id的方法

5、点击“运行”

易语言获取进程id的方法

6、点击“按钮”

易语言获取进程id的方法

7、进程ID就出来了

易语言获取进程id的方法


上一篇:易语言读取Word文档方法下一篇:易语言给文件加密的方法
程序园_程序员的世界 Copyright © 2020- www.580doc.com. Some Rights Reserved.