首页 » 软件编程 » 易语言

易语言制作图标提取器方法

易语言 2021-12-12

图标提取器网上也很多这样的工具,这里我们就用易语言自己做一个,本人也是一边学边应用,代码不一定好,只给大家参考学习用

易语言制作图标提取器方法

1、我们先做好图标提取器的界面,添加两个按钮,两个编辑框,适当更改一下窗口的标题和标签说明

易语言制作图标提取器方法

2、接着增加一个图片框,设置为凹入式,背景颜色为白,添加标签说明接着增加一个图片框,设置为凹入式,背景颜色为白,添加标签说明

3、接着再添加两个通用对话框,通用对话模型1类型设置为“保存文件”,通用对话框2类型设置为”打开文件“

易语言制作图标提取器方法

易语言制作图标提取器方法

4、界面做好了,再看代码部分,先添加两个程序集变量

易语言制作图标提取器方法

5、按钮打开被单击事件下代码

.版本 2

.支持库 iext2

通用对话框2.过滤器 = “程序文件(*.exe)|*.exe”

.如果真 (通用对话框2.打开 ())

  编辑框1.内容 = 通用对话框2.文件名

  图片组 = 建空图片组 (32, 32)

  图标索引 = 提取加入图片 (图片组, 编辑框1.内容, , )

  图片框1.图片 = 取图片组图片 (图片组, 图标索引, )

.如果真结束

易语言制作图标提取器方法

6、按钮保存被单击事件下代码

.版本 2

.支持库 eAPI

通用对话框1.过滤器 = “图标文件(*.ico)|*.ico)”

.如果真 (通用对话框1.打开 ())

  编辑框2.内容 = 通用对话框1.文件名 + “.ico”

.如果真结束

.如果真 (编辑框2.内容 = “”)

  信息框 (“你还没有选择要保存的目录”, #错误图标, “警告”)

.如果真结束

.如果真 (编辑框2.内容 ≠ “”)

  信息框 (“图标已保存到:” + #换行符 + 编辑框2.内容 + #换行符, #信息图标, “提示”)

  提取资源文件图标 (编辑框1.内容, 0, 编辑框2.内容, )

易语言制作图标提取器方法

总结:上面就是关于易语言制作图标提取器的全部内容,感谢大家的阅读和对www.580doc.com的支持。


上一篇:易语言超文本组件使用详解下一篇:易语言九九乘除加减表制作方法
程序园_程序员的世界 Copyright © 2020- www.580doc.com. Some Rights Reserved.